Email Sending Service Degradation
Incident Report for Splash
Resolved
After further investigation, email deliverability is no longer impacted and the platform is functioning as expected. Email analytics may be delayed in appearing within the Email Sender UI, but deliverability processes are operating at expected capacity.
Posted Jul 18, 2024 - 22:07 UTC
Investigating
Splash is currently experiencing delays in sending emails. We are investigating this issue with our sub-processors and will be ensuring that email functionality becomes fully operational.
Posted Jul 18, 2024 - 20:51 UTC
This incident affected: Splash Email Sender (Deliverability).