Splash Is Experiencing Site-Wide Downtime
Incident Report for Splash
Postmortem
Issue summary:

The platform experienced brief inaccessibility, displaying a 505 (or similar) errors due to the database being under high traffic load and increased activity.

 

Issue timeframe:

February 7th, 2024 10:37 AM EST - February 7th, 2024 10:58 AM EST (21 minutes)

Sequence of events:
  • February 7th, 10:37 AM EST System down alert fires; investigation started.
  • February 7th, 10:45 AM EST Determined that database connections started to spike at approximately 10:30 AM EST.
  • February 7th, 10:50 AM EST System impact identified, and root cause traced to an abnormally elevated concurrence of email sends, API calls, and increased platform activity.
  • February 7th, 10:52 AM EST Source(s) identified to be causing high load and breaching autoscaling expectations.
  • February 7th, 10:55 AM EST Platform regained responsiveness and access was reinstated.
  • February 7th, 10:58 AM EST Platform confirmed fully restored.

Root cause:

An abnormally large concurrence of email sends, API calls, and general platform activity resulted in ​​high database load. Connection and volume management processes failed to adequately manage the thread consumption, leading to temporary platform access unavailability.

Steps to prevent recurrence:
  • Autoscaling and volume management processes will be optimized to appropriately handle similar scenarios.
Posted Feb 09, 2024 - 23:29 UTC

Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 16:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2024 - 16:03 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 07, 2024 - 16:02 UTC
Investigating
Splash is presently experiencing a site-wide issue and is unavailable. We are investigating the underlying cause of this issue.
Posted Feb 07, 2024 - 15:45 UTC
This incident affected: AWS (Amazon Web Services) (AWS ec2-us-east-1, AWS s3-sa-east-1, AWS dynamodb-us-east-1), Guest Experience (Guest RSVP, Guest Ticketing, Event Pages, Virtual Events), Logged In Experience (Event Page Design (CMS), Guest List Management (RSVP & Ticketed), Event Creation, Team Management, Analytics & Reporting, Email Design, User Login, Event Settings), Splash Integrations (Integrations Queue, Zoom, Marketo, HubSpot, Salesforce, On24, BlueJeans, Eloqua, Slack, Splash API, Pardot, Greenhouse, Zapier, Yext, Splash Studio), Splash API, Splash Email Sender (Deliverability), EMEA Region (Europe), Mobile Host App (iOS), Mobile Host App (Android), and Payment Processing (Stripe API, Stripe Checkout.js, Braintree).