Splash is investigating delays sending emails
Incident Report for Splash
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 22:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2024 - 20:12 UTC
Investigating
We are currently investigating issues with tracking links using info.splashthat.com.

Additionally, we are investigating email send delays.These are unrelated issues, and teams are working to address both issues immediately.
Posted Jan 18, 2024 - 19:01 UTC
This incident affected: Splash Email Sender (Deliverability).