Splash Is Experiencing Loading Delays
Incident Report for Splash
Postmortem
Issue summary:

The platform experienced an unexpected surge in traffic that significantly exceeded normal levels resulting in slower-than-usual response times across all Splash services.

 

Issue timeframe:

April 3, 2024, 12:51 PM EST to 1:57 PM EST (1 hour 06 mins)

Sequence of events:
  • April 3rd, 12:51 PM EST - First internal alert received; investigation started.
  • April 3rd, 12:56 PM EST - System impact identified; root cause traced to an abnormally elevated number of incoming traffic and resulting API calls.
  • April 3rd, 1:13 PM EST - Restorative actions taken to decrease impact on the platform.
  • April 3rd, 1:25 PM EST - Manual scaling of resources implemented within the database. 
  • April 3rd, 1:30 PM EST - Performance returned to 100% adjusting the incident to Monitoring status.
  • April 3rd, 1:57 PM EST - Incident adjusted to Resolved status.

Root cause:

Splash encountered an unexpected spike in traffic that significantly exceeded normal levels.

The autoscaling mechanisms set in place, and designed to adjust resources based on demand, did not perform as anticipated. 

This resulted in slower-than-usual response times across all Splash services.

Steps to prevent recurrence:
  • Splash to adjust autoscaling and alerting metrics.
  • Splash to update logic to accommodate increased traffic within the platform.
  • Splash to investigate the source of traffic at the time of degraded performance.
Posted Apr 08, 2024 - 17:06 UTC

Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 17:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2024 - 17:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 03, 2024 - 17:29 UTC
Investigating
Splash is presently experiencing an issue with log-in. Some users may be temporarily unable to log in. We are investigating the underlying cause of this issue.
Posted Apr 03, 2024 - 16:49 UTC
This incident affected: Guest Experience (Guest RSVP, Event Pages, Virtual Events) and Logged In Experience (Event Page Design (CMS), Guest List Management (RSVP & Ticketed), Event Creation, Team Management, Analytics & Reporting, Email Design, User Login, Event Settings).