Splash is investigating delays sending emails
Incident Report for Splash
Postmortem
Issue summary:

One of our email sending domains was temporarily disabled, which resulted in the subset of users associated with that specific domain not to be able to send any emails from the platform. This also caused links within emails sent from this domains to become unavailable.

Issue timeframe:

March 21st, 2024 08:00 AM EST to 12:50 PM EST (4 hours 50 mins).

Sequence of events:
  • March 21, 08:00 AM EST First communication around the domain being flagged received; investigation started.
  • March 21, 09:15 AM EST Conversation with our email provider starts to align on overall impact of the situation and the measures needed to restore the service.
  • March 21, 12:50 PM EST All functionalities fully restored.
Root cause:

Due to an email resulting in high reports of spam, our third-party email subprocessor restricted sending from one of our sending domains. 

Steps to prevent recurrence:
  • Splash is exploring more comprehensive security measures to put in place for spam email prevention to guests. 
  • Splash has implemented a notification process when potential spam emails are sent out.
Posted Mar 26, 2024 - 16:05 UTC

Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 17:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2024 - 17:10 UTC
Update
We have narrowed down the list of affected customers and will be reaching out to all those affected.
Posted Mar 21, 2024 - 13:40 UTC
Identified
We have identified the issue with our email sends and are actively working with our service provider to resolve it.
Posted Mar 21, 2024 - 13:23 UTC
Investigating
We are currently investigating delays in sending emails.
Posted Mar 21, 2024 - 12:48 UTC
This incident affected: Splash Email Sender (Deliverability).