Splash is Experiencing Elevated Errors
Incident Report for Splash
Postmortem

Issue summary:

At 12:00 PM ET on March 11, 2024, Splash experienced performance degradation including delayed and stuck email sending, failed RSVPs, and touchpoint loading issues. The service interruption was found to be caused by a long-running query that prevented other processes like RSVPs or Contacts operations from performing correctly. Services were fully restored by 1:11 PM ET.

Issue timeframe:

March 11, 2024 from 11:11 AM ET to 1:11 PM ET (2 hours)

Sequence of events:

  • March 11, 2024, 11:11 AM ET: Internal system monitoring alerts that queries to the Splash contacts database are slowing.
  • 12:00 PM ET: First customer reports of failures received by Support.
  • 12:09 PM ET: Internal alerts received; investigation started.
  • 12:49 PM ET: System impact identified, and root cause traced to a long-running query that blocked other processes.
  • 1:11 PM ET: All problematic queries and processes were eliminated, and services were fully restored.

Root cause:

A query process overconsumed Splash resources, blocking other processes from being executed properly, leading to performance degradation in other areas as a side effect.

Steps to prevent recurrence:

  • Splash to run query processes in contained environments to monitor for and prevent significant performance impact.
Posted Mar 14, 2024 - 00:39 UTC

Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 17:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2024 - 17:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 11, 2024 - 16:40 UTC
Investigating
We're experiencing an elevated level of API errors that impact email sending and registration form submission. We are currently looking into the issue.
Posted Mar 11, 2024 - 16:20 UTC
This incident affected: Guest Experience (Guest RSVP), Splash API, Splash Email Sender (Deliverability), and Logged In Experience (Analytics & Reporting).