Email Sending Service Degradation
Incident Report for Splash
Resolved
This incident has been resolved.
Posted Nov 23, 2022 - 22:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 23, 2022 - 20:53 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 23, 2022 - 19:07 UTC
Monitoring
We are currently affected by email sending delays as a result of a sub-processor outage. We are monitoring our sub-processor and will be ensuring that email functionality becomes fully operational as soon as their outage is resolved.
Posted Nov 23, 2022 - 19:05 UTC
This incident affected: Splash Email Sender (Deliverability) and EMEA Region (Europe).